use strict;
my $str = 'smsKod: 24992129 dla
operacji: zmiana limitów
transakcyjnych 27.03.2015
11.17';
my $regex = qr/[\s\S]*smsKod: (\d{8})[\s\S]*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}