package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s\S]*smsKod: (\d{8})[\s\S]*`)
var str = `smsKod: 24992129 dla
operacji: zmiana limitów
transakcyjnych 27.03.2015
11.17`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}