// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\s\S]*smsKod: (\d{8})[\s\S]*").unwrap();
let string = "smsKod: 24992129 dla
operacji: zmiana limitów
transakcyjnych 27.03.2015
11.17";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}