# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[,.]\d+$|[.,]//gm;t' <<< "111.112.123,55
123.44
123,353,123.55
21,23
152.00
111112123
123
123353123
21
152"