using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[,.]\d+$|[.,]";
string substitution = @"";
string input = @"111.112.123,55
123.44
123,353,123.55
21,23
152.00
111112123
123
123353123
21
152";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}