// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[,.]\d+$|[.,]").unwrap();
let string = "111.112.123,55
123.44
123,353,123.55
21,23
152.00
111112123
123
123353123
21
152";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}