use strict;
my $str = '111.112.123,55
123.44
123,353,123.55
21,23
152.00
111112123
123
123353123
21
152';
my $regex = qr/[,.]\d+$|[.,]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";