import re
regex = re.compile(r"[,.]\d+$|[.,]", flags=re.MULTILINE)
test_str = ("111.112.123,55\n"
"123.44\n"
"123,353,123.55\n"
"21,23\n"
"152.00\n\n"
"111112123\n"
"123\n"
"123353123\n"
"21\n"
"152")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)