const regex = /[,.]\d+$|[.,]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[,.]\\d+$|[.,]', 'gm')
const str = `111.112.123,55
123.44
123,353,123.55
21,23
152.00
111112123
123
123353123
21
152`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);