$re = '/[,.]\d+$|[.,]/m';
$str = '111.112.123,55
123.44
123,353,123.55
21,23
152.00
111112123
123
123353123
21
152';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;