import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[,.]\\d+$|[.,]";
final String string = "111.112.123,55\n"
+ "123.44\n"
+ "123,353,123.55\n"
+ "21,23\n"
+ "152.00\n\n"
+ "111112123\n"
+ "123\n"
+ "123353123\n"
+ "21\n"
+ "152";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}