# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z]{3}) (\d 2}), (\d{4})/$2-$1-$3/;t' <<< "Nov 6 2022"