use strict;
my $str = 'Nov 6 2022';
my $regex = qr/([a-zA-Z]{3}) (\d 2}), (\d{4})/p;
my $subst = '$2-$1-$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";