re = /([a-zA-Z]{3}) (\d 2}), (\d{4})/
str = 'Nov 6 2022'
subst = '$2-$1-$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result