// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z]{3}) (\d 2}), (\d{4})").unwrap();
let string = "Nov 6 2022";
let substitution = "$2-$1-$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}