import Foundation
let pattern = #"([a-zA-Z]{3}) (\d 2}), (\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Nov 6 2022"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2-$1-$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}