# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)/$1$value$2$XPath/gm;t' <<< "of John at /roger/adam1/sam dfd"