import Foundation
let pattern = #"(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"of John at /roger/adam1/sam dfd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$value$2$XPath"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)