$re = '/(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)/m';
$str = 'of John at /roger/adam1/sam dfd';
$subst = "$1$value$2$XPath";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;