#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)"
Local $sString = "of John at /roger/adam1/sam dfd"
Local $sSubst = "$1$value$2$XPath"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)