re = /(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)/m
str = 'of John at /roger/adam1/sam dfd'
subst = '$1$value$2$XPath'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result