using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)";
string substitution = @"$1$value$2$XPath";
string input = @"of John at /roger/adam1/sam dfd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}