const regex = /(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(of\\s*)[a-zA-Z\\d]+(\\s*at\\s*).*(?=\\s)', 'gm')
const str = `of John at /roger/adam1/sam dfd`;
const subst = `$1$value$2$XPath`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);