#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d)(%)"
Local $sString = "This is 55% of the total." & @CRLF & _
"" & @CRLF & _
"% a comment" & @CRLF & _
""
Local $sSubst = "$1\\$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)