import re
regex = re.compile(r"(\d)(%)", flags=re.MULTILINE)
test_str = ("This is 55% of the total.\n\n"
"% a comment\n")
subst = "$1\\\\$2"
result = regex.sub(subst, test_str)
if result:
print(result)