use strict;
my $str = 'This is 55% of the total.
% a comment
';
my $regex = qr/(\d)(%)/mp;
my $subst = '$1\\\\$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";