$re = '/(\d)(%)/m';
$str = 'This is 55% of the total.
% a comment
';
$subst = "$1\\$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;