re = /(\d)(%)/m
str = 'This is 55% of the total.
% a comment
'
subst = '$1\\\\$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result