package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d)(%)`)
var str = `This is 55% of the total.
% a comment
`
var substitution = "$1\\$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}