# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bto\b(?:(?!\bto\b).)*?CITY\d+//gs;t' <<< "John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days"