#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\bto\b(?:(?!\bto\b).)*?CITY\d+"
Local $sString = "John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)