import Foundation
let pattern = #"\bto\b(?:(?!\bto\b).)*?CITY\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)