re = /\bto\b(?:(?!\bto\b).)*?CITY\d+/
str = 'John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result