using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bto\b(?:(?!\bto\b).)*?CITY\d+";
string substitution = @"";
string input = @"John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}