# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bto\b(?:(?!\bto\b).)*?CITY\d+"
test_str = "John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.