$re = '/\bto\b(?:(?!\bto\b).)*?CITY\d+/s';
$str = 'John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;