use strict;
my $str = 'John from beautiful CITY1 in sdfsf to dsfs in sf to abc CITY2 to CITY3 for 3 days';
my $regex = qr/\bto\b(?:(?!\bto\b).)*?CITY\d+/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";