using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",? *(?P<weekDays>[^\d:\n]+):? *(?P<startTime>[^,\n]+)";
string input = @"Tue.-Wed.: 17.45 μεταγλ.
Thur., Wed.: 20.00
Thur.-Wed.: 18.15/ 20.15 μεταγλ.
Thur.-Wed.: 21.15
Thur.-Sun., Τρ., Τετ.: 21.10
Sat., Sun.: 18.10 μεταγλ.
Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.
Wed. 9 μ.μ.
Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}