$re = '/,? *(?P<weekDays>[^\d:\n]+):? *(?P<startTime>[^,\n]+)/m';
$str = 'Tue.-Wed.: 17.45 μεταγλ.
Thur., Wed.: 20.00
Thur.-Wed.: 18.15/ 20.15 μεταγλ.
Thur.-Wed.: 21.15
Thur.-Sun., Τρ., Τετ.: 21.10
Sat., Sun.: 18.10 μεταγλ.
Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.
Wed. 9 μ.μ.
Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);