import re
regex = re.compile(r",? *(?P<weekDays>[^\d:\n]+):? *(?P<startTime>[^,\n]+)", flags=re.MULTILINE)
test_str = ("Tue.-Wed.: 17.45 μεταγλ.\n"
"Thur., Wed.: 20.00\n"
"Thur.-Wed.: 18.15/ 20.15 μεταγλ.\n"
"Thur.-Wed.: 21.15\n"
"Thur.-Sun., Τρ., Τετ.: 21.10\n"
"Sat., Sun.: 18.10 μεταγλ.\n"
"Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.\n"
"Wed. 9 μ.μ.\n"
"Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")