const regex = new RegExp(',? *(?P<weekDays>[^\\d:\\n]+):? *(?P<startTime>[^,\\n]+)', 'gm')
const str = `Tue.-Wed.: 17.45 μεταγλ.
Thur., Wed.: 20.00
Thur.-Wed.: 18.15/ 20.15 μεταγλ.
Thur.-Wed.: 21.15
Thur.-Sun., Τρ., Τετ.: 21.10
Sat., Sun.: 18.10 μεταγλ.
Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.
Wed. 9 μ.μ.
Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}