import Foundation
let pattern = #",? *(?P<weekDays>[^\d:\n]+):? *(?P<startTime>[^,\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Tue.-Wed.: 17.45 μεταγλ.
Thur., Wed.: 20.00
Thur.-Wed.: 18.15/ 20.15 μεταγλ.
Thur.-Wed.: 21.15
Thur.-Sun., Τρ., Τετ.: 21.10
Sat., Sun.: 18.10 μεταγλ.
Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.
Wed. 9 μ.μ.
Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)