// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m),? *(?P<weekDays>[^\d:\n]+):? *(?P<startTime>[^,\n]+)").unwrap();
let string = "Tue.-Wed.: 17.45 μεταγλ.
Thur., Wed.: 20.00
Thur.-Wed.: 18.15/ 20.15 μεταγλ.
Thur.-Wed.: 21.15
Thur.-Sun., Τρ., Τετ.: 21.10
Sat., Sun.: 18.10 μεταγλ.
Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.
Wed. 9 μ.μ.
Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}