import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",? *(?P<weekDays>[^\\d:\\n]+):? *(?P<startTime>[^,\\n]+)";
final String string = "Tue.-Wed.: 17.45 μεταγλ.\n"
+ "Thur., Wed.: 20.00\n"
+ "Thur.-Wed.: 18.15/ 20.15 μεταγλ.\n"
+ "Thur.-Wed.: 21.15\n"
+ "Thur.-Sun., Τρ., Τετ.: 21.10\n"
+ "Sat., Sun.: 18.10 μεταγλ.\n"
+ "Thur., Fri., Sat., Sun., Tue., Wed. 9 μ.μ.\n"
+ "Wed. 9 μ.μ.\n"
+ "Thur.-Sun., Tue., Wed.: 20.50/ 23.00, Mon. 23.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}