# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})/$7$3$1$2$6$4$1/g;t' <<< " [1] 2 3 4 5 6 7 8 9 "