const regex = /(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})([a-zA_Z0-9]*)(\\s{3})', 'g')
const str = ` [1] 2 3 4 5 6 7 8 9 `;
const subst = `$7$3$1$2$6$4$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);