import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})([a-zA_Z0-9]*)(\\s{3})";
final String string = " [1] 2 3 4 5 6 7 8 9 ";
final String subst = "$7$3$1$2$6$4$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}