using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})";
string substitution = @"$7$3$1$2$6$4$1";
string input = @" [1] 2 3 4 5 6 7 8 9 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}