re = /(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})/
str = ' [1] 2 3 4 5 6 7 8 9 '
subst = '$7$3$1$2$6$4$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result