$re = '/(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})([a-zA_Z0-9]*)(\s{3})/';
$str = ' [1] 2 3 4 5 6 7 8 9 ';
$subst = "$7$3$1$2$6$4$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;